$re = '/(?<link_all>
(?<!\\\\)\[
(?<link_name>
(?>\\\\[\[\]]|[^\[\]])*+
)
(?<!\\\\)\]
(?:
(?:
[ ]?
(?:\n[ ]*)?
(?<!\\\\)\[(?<link_id>.*?)(?<!\\\\)\]
)
|
(?:
(?<!\\\\)\(
[ \t]*
(?:
<(?<link_url>.*?)>
|
(?<link_url>.*?)
)
[ \t]*
(?:
(?<link_title_container>[\'"])
(?<link_title>.*?)
\g{link_title_container}
)?
(?<!\\\\)\)
(?![[:blank:]\h]+["\'][^"\']+["\'])
)
)
)/mxJs';
$str = '[Inline link 3 with non-escaped parens](/url(test) "title")
Foo [bar]
This one has a [line
break][].
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);