re = /(?<link_all>
(?<!\\)\[
(?<link_name>
(?>\\[\[\]]|[^\[\]])*+
)
(?<!\\)\]
(?:
(?:
[ ]?
(?:\n[ ]*)?
(?<!\\)\[(?<link_id>.*?)(?<!\\)\]
)
|
(?:
(?<!\\)\(
[ \t]*
(?:
<(?<link_url>.*?)>
|
(?<link_url>.*?)
)
[ \t]*
(?:
(?<link_title_container>['"])
(?<link_title>.*?)
\g{link_title_container}
)?
(?<!\\)\)
(?![[:blank:]\h]+["'][^"']+["'])
)
)
)/mx
str = '[Inline link 3 with non-escaped parens](/url(test) "title")
Foo [bar]
This one has a [line
break][].
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end