import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<link_all>\n"
+ " (?<!\\\\)\\[\n"
+ " (?<link_name>\n"
+ " (?>\\\\[\\[\\]]|[^\\[\\]])*+\n"
+ " )\n"
+ " (?<!\\\\)\\]\n"
+ " (?:\n"
+ " (?:\n"
+ " [ ]?\n"
+ " (?:\\n[ ]*)?\n"
+ " (?<!\\\\)\\[(?<link_id>.*?)(?<!\\\\)\\]\n"
+ " )\n"
+ " |\n"
+ " (?:\n"
+ " (?<!\\\\)\\(\n"
+ " [ \\t]*\n"
+ " (?:\n"
+ " <(?<link_url>.*?)>\n"
+ " |\n"
+ " (?<link_url>.*?)\n"
+ " )\n"
+ " [ \\t]*\n"
+ " (?:\n"
+ " (?<link_title_container>['\"])\n"
+ " (?<link_title>.*?)\n"
+ " \\g\\{link_title_container\\}\n"
+ " )?\n"
+ " (?<!\\\\)\\)\n"
+ " (?![[:blank:]\\h]+[\"'][^\"']+[\"'])\n"
+ " )\n"
+ " )\n"
+ ")";
final String string = "[Inline link 3 with non-escaped parens](/url(test) \"title\")\n\n"
+ "Foo [bar]\n\n"
+ "This one has a [line\n"
+ "break][].\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}