#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\?|\&)(?<key>[\w]+)=(?<value>[\w+,-]+)(?:\:?)(?<option>[\w,]*)"
Local $sString = "<link href='http://fonts.googleapis.com/css?family=Open+Sans:800italic,400,300&subset=latin-ext,latin,greek' rel='stylesheet' type='text/css'>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")