package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\?|\&)(?<key>[\w]+)=(?<value>[\w+,-]+)(?:\:?)(?<option>[\w,]*)`)
var str = `<link href='http://fonts.googleapis.com/css?family=Open+Sans:800italic,400,300&subset=latin-ext,latin,greek' rel='stylesheet' type='text/css'>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}