re = /(?:\?|\&)(?<key>[\w]+)=(?<value>[\w+,-]+)(?:\:?)(?<option>[\w,]*)/
str = '<link href=\'http://fonts.googleapis.com/css?family=Open+Sans:800italic,400,300&subset=latin-ext,latin,greek\' rel=\'stylesheet\' type=\'text/css\'>'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end