import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\?|\\&)(?<key>[\\w]+)=(?<value>[\\w+,-]+)(?:\\:?)(?<option>[\\w,]*)";
final String string = "<link href='http://fonts.googleapis.com/css?family=Open+Sans:800italic,400,300&subset=latin-ext,latin,greek' rel='stylesheet' type='text/css'>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}