using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\?|\&)(?<key>[\w]+)=(?<value>[\w+,-]+)(?:\:?)(?<option>[\w,]*)";
string input = @"<link href='http://fonts.googleapis.com/css?family=Open+Sans:800italic,400,300&subset=latin-ext,latin,greek' rel='stylesheet' type='text/css'>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}