using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=\P{L})(?=(?:\p{Lu}\h+){2}\p{Lu})|\G(?!\A))\p{Lu}\K\h+(?=\p{Lu}(?!\p{L}))";
string substitution = @"";
string input = @"Welcome to A I: the best W O R L D!
Hi I R is the B O M B for sure: weA É A G R E E Éindeed.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}