use strict;
my $str = 'Welcome to A I: the best W O R L D!
Hi I R is the B O M B for sure: weA É A G R E E Éindeed.';
my $regex = qr/(?:(?<=\P{L})(?=(?:\p{Lu}\h+){2}\p{Lu})|\G(?!\A))\p{Lu}\K\h+(?=\p{Lu}(?!\p{L}))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";