#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]{0,9}(-[0-9]{0,4})?$"
Local $sString = "NoBcAl" & @CRLF & _
"A" & @CRLF & _
"-" & @CRLF & _
"9-" & @CRLF & _
"-9" & @CRLF & _
"-" & @CRLF & _
"9-" & @CRLF & _
"99-" & @CRLF & _
"999-" & @CRLF & _
"9999-" & @CRLF & _
"99999-" & @CRLF & _
"999999-" & @CRLF & _
"9999999-" & @CRLF & _
"99999999-" & @CRLF & _
"999999999" & @CRLF & _
"9999999999" & @CRLF & _
"9999999999-" & @CRLF & _
"9999999999-9" & @CRLF & _
"999999999-" & @CRLF & _
"999999999-9" & @CRLF & _
"999999999-99" & @CRLF & _
"999999999-999" & @CRLF & _
"999999999-9999" & @CRLF & _
"999999999--9999" & @CRLF & _
"999999999-99999" & @CRLF & _
"999999999-999999" & @CRLF & _
"999999999-999999-" & @CRLF & _
"-9" & @CRLF & _
"-99" & @CRLF & _
"-999" & @CRLF & _
"-9999" & @CRLF & _
"-99999" & @CRLF & _
"9-9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")