import Foundation
let pattern = #"^[0-9]{0,9}(-[0-9]{0,4})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
NoBcAl
A
-
9-
-9
-
9-
99-
999-
9999-
99999-
999999-
9999999-
99999999-
999999999
9999999999
9999999999-
9999999999-9
999999999-
999999999-9
999999999-99
999999999-999
999999999-9999
999999999--9999
999999999-99999
999999999-999999
999999999-999999-
-9
-99
-999
-9999
-99999
9-9
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)