re = /^[0-9]{0,9}(-[0-9]{0,4})?$/m
str = 'NoBcAl
A
-
9-
-9
-
9-
99-
999-
9999-
99999-
999999-
9999999-
99999999-
999999999
9999999999
9999999999-
9999999999-9
999999999-
999999999-9
999999999-99
999999999-999
999999999-9999
999999999--9999
999999999-99999
999999999-999999
999999999-999999-
-9
-99
-999
-9999
-99999
9-9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end