import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]{0,9}(-[0-9]{0,4})?$";
final String string = "NoBcAl\n"
+ "A\n"
+ "-\n"
+ "9-\n"
+ "-9\n"
+ "-\n"
+ "9-\n"
+ "99-\n"
+ "999-\n"
+ "9999-\n"
+ "99999-\n"
+ "999999-\n"
+ "9999999-\n"
+ "99999999-\n"
+ "999999999\n"
+ "9999999999\n"
+ "9999999999-\n"
+ "9999999999-9\n"
+ "999999999-\n"
+ "999999999-9\n"
+ "999999999-99\n"
+ "999999999-999\n"
+ "999999999-9999\n"
+ "999999999--9999\n"
+ "999999999-99999\n"
+ "999999999-999999\n"
+ "999999999-999999-\n"
+ "-9\n"
+ "-99\n"
+ "-999\n"
+ "-9999\n"
+ "-99999\n"
+ "9-9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}