$re = '/^[0-9]{0,9}(-[0-9]{0,4})?$/m';
$str = 'NoBcAl
A
-
9-
-9
-
9-
99-
999-
9999-
99999-
999999-
9999999-
99999999-
999999999
9999999999
9999999999-
9999999999-9
999999999-
999999999-9
999999999-99
999999999-999
999999999-9999
999999999--9999
999999999-99999
999999999-999999
999999999-999999-
-9
-99
-999
-9999
-99999
9-9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);