package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`270?(\d{9})`)
var str = `0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
27123456789
270123456789`
var substitution = "0\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}