const regex = /270?(\d{9})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('270?(\\d{9})', 'g')
const str = `0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
27123456789
270123456789`;
const subst = `0\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);