use strict;
my $str = '0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
27123456789
270123456789';
my $regex = qr/270?(\d{9})/p;
my $subst = '0\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";