using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"configuration|config";
string substitution = @"configuration";
string input = @"config
testconfig
configuration
testconfigurationtest
configtesting";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}