use strict;
my $str = 'config
testconfig
configuration
testconfigurationtest
configtesting';
my $regex = qr/configuration|config/mp;
my $subst = 'configuration';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";