package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)configuration|config`)
var str = `config
testconfig
configuration
testconfigurationtest
configtesting`
var substitution = "configuration"
fmt.Println(re.ReplaceAllString(str, substitution))
}