// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)configuration|config").unwrap();
let string = "config
testconfig
configuration
testconfigurationtest
configtesting";
let substitution = "configuration";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}