import Foundation
let pattern = #"configuration|config"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
config
testconfig
configuration
testconfigurationtest
configtesting
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"configuration"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)