using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*(?<=\\))?+(.*$|$)";
string input = @"C:\Path1.Ext1\File1.v1.Ext1
C:\Path2.Ext2\File2.Ext2
C:\Path3.Ext3\File3.
C:\Path4.Ext4\File4
C:\Path5.Ext5\.Ext5
File6.v1.Ext6
File7.Ext7
File8.
File9
.Ext10
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}