const regex = /^(.*(?<=\\))?+(.*$|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*(?<=\\\\))?+(.*$|$)', 'gm')
const str = `C:\\Path1.Ext1\\File1.v1.Ext1
C:\\Path2.Ext2\\File2.Ext2
C:\\Path3.Ext3\\File3.
C:\\Path4.Ext4\\File4
C:\\Path5.Ext5\\.Ext5
File6.v1.Ext6
File7.Ext7
File8.
File9
.Ext10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}