import Foundation
let pattern = #"^(.*(?<=\\))?+(.*$|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
C:\Path1.Ext1\File1.v1.Ext1
C:\Path2.Ext2\File2.Ext2
C:\Path3.Ext3\File3.
C:\Path4.Ext4\File4
C:\Path5.Ext5\.Ext5
File6.v1.Ext6
File7.Ext7
File8.
File9
.Ext10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)