$re = '/^(.*(?<=\\\\))?+(.*$|$)/m';
$str = 'C:\\Path1.Ext1\\File1.v1.Ext1
C:\\Path2.Ext2\\File2.Ext2
C:\\Path3.Ext3\\File3.
C:\\Path4.Ext4\\File4
C:\\Path5.Ext5\\.Ext5
File6.v1.Ext6
File7.Ext7
File8.
File9
.Ext10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);