import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*(?<=\\\\))?+(.*$|$)";
final String string = "C:\\Path1.Ext1\\File1.v1.Ext1\n"
+ "C:\\Path2.Ext2\\File2.Ext2\n"
+ "C:\\Path3.Ext3\\File3.\n"
+ "C:\\Path4.Ext4\\File4\n"
+ "C:\\Path5.Ext5\\.Ext5\n"
+ "File6.v1.Ext6\n"
+ "File7.Ext7\n"
+ "File8.\n"
+ "File9\n"
+ ".Ext10\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}