import re
regex = re.compile(r"^(.*(?<=\\))?+(.*$|$)", flags=re.MULTILINE)
test_str = ("C:\\Path1.Ext1\\File1.v1.Ext1\n"
"C:\\Path2.Ext2\\File2.Ext2\n"
"C:\\Path3.Ext3\\File3.\n"
"C:\\Path4.Ext4\\File4\n"
"C:\\Path5.Ext5\\.Ext5\n"
"File6.v1.Ext6\n"
"File7.Ext7\n"
"File8.\n"
"File9\n"
".Ext10\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")