#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*([0-9]{5})"
Local $sString = "D012345" & @CRLF & _
"D012345AS" & @CRLF & _
"D012345RM-67" & @CRLF & _
"D12345D" & @CRLF & _
"12345D67-foo98765" & @CRLF & _
"TEST-Str12345ing-rm6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")