using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*([0-9]{5})";
string input = @"D012345
D012345AS
D012345RM-67
D12345D
12345D67-foo98765
TEST-Str12345ing-rm6";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}