package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*([0-9]{5})`)
var str = `D012345
D012345AS
D012345RM-67
D12345D
12345D67-foo98765
TEST-Str12345ing-rm6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}