import Foundation
let pattern = #".*([0-9]{5})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
D012345
D012345AS
D012345RM-67
D12345D
12345D67-foo98765
TEST-Str12345ing-rm6
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)