// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*([0-9]{5})").unwrap();
let string = "D012345
D012345AS
D012345RM-67
D12345D
12345D67-foo98765
TEST-Str12345ing-rm6";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}