using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\*\s*)(?'comment'.*?)(\s*\*\/)";
string input = @"/***************************** Шапка Ñтраницы *********************************/
/*****/
/*----------------------------------------------------------------------------------------------------------------------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*------ ------*/
/*------ Внимание! Ðтот файл Ñодержит огромное количеÑтво Ñтилей ------*/
/*------ Ðе пытайтеÑÑŒ найти здеÑÑŒ что-то вручную ------*/
/*------ Ð”Ð»Ñ Ð¿Ð¾Ð¸Ñка Ð½Ð°Ð·Ð²Ð°Ð½Ð¸Ñ Ð½ÑƒÐ¶Ð½Ð¾Ð³Ð¾ ÑÑ‚Ð¸Ð»Ñ Ð¸Ñпользуйте Firebug: ------*/
/*------ http://articles/chto-takoe-firebug-i-pochemu-ego-objazatelno-nado-ustanovit.html ------*/
/*------ ------*/
/*------ Краткое руководÑтво по Ñозданию шаблона: ------*/
/*------ http://articles/sozdanie-shablona.html ------*/
/*------ ------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*
tttttttttttttt
*/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}