$re = '/(\/\*\s*)(?\'comment\'.*?)(\s*\*\/)/';
$str = '/***************************** Шапка Ñтраницы *********************************/
/*****/
/*----------------------------------------------------------------------------------------------------------------------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*------ ------*/
/*------ Внимание! Ðтот файл Ñодержит огромное количеÑтво Ñтилей ------*/
/*------ Ðе пытайтеÑÑŒ найти здеÑÑŒ что-то вручную ------*/
/*------ Ð”Ð»Ñ Ð¿Ð¾Ð¸Ñка Ð½Ð°Ð·Ð²Ð°Ð½Ð¸Ñ Ð½ÑƒÐ¶Ð½Ð¾Ð³Ð¾ ÑÑ‚Ð¸Ð»Ñ Ð¸Ñпользуйте Firebug: ------*/
/*------ http://articles/chto-takoe-firebug-i-pochemu-ego-objazatelno-nado-ustanovit.html ------*/
/*------ ------*/
/*------ Краткое руководÑтво по Ñозданию шаблона: ------*/
/*------ http://articles/sozdanie-shablona.html ------*/
/*------ ------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*
tttttttttttttt
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);