import re
regex = re.compile(r"(\/\*\s*)(?'comment'.*?)(\s*\*\/)")
test_str = ("/***************************** Шапка Ñтраницы *********************************/\n"
"/*****/\n"
"/*----------------------------------------------------------------------------------------------------------------------*/\n"
"/*----------------------------------------------------------------------------------------------------------------------*/\n"
"/*------ ------*/\n"
"/*------ Внимание! Ðтот файл Ñодержит огромное количеÑтво Ñтилей ------*/\n"
"/*------ Ðе пытайтеÑÑŒ найти здеÑÑŒ что-то вручную ------*/\n"
"/*------ Ð”Ð»Ñ Ð¿Ð¾Ð¸Ñка Ð½Ð°Ð·Ð²Ð°Ð½Ð¸Ñ Ð½ÑƒÐ¶Ð½Ð¾Ð³Ð¾ ÑÑ‚Ð¸Ð»Ñ Ð¸Ñпользуйте Firebug: ------*/\n"
"/*------ http://articles/chto-takoe-firebug-i-pochemu-ego-objazatelno-nado-ustanovit.html ------*/\n"
"/*------ ------*/\n"
"/*------ Краткое руководÑтво по Ñозданию шаблона: ------*/\n"
"/*------ http://articles/sozdanie-shablona.html ------*/\n"
"/*------ ------*/\n"
"/*----------------------------------------------------------------------------------------------------------------------*/\n"
"/*----------------------------------------------------------------------------------------------------------------------*/\n\n"
"/*\n"
"tttttttttttttt\n"
"*/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")