// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\/\*\s*)(?'comment'.*?)(\s*\*\/)").unwrap();
let string = "/***************************** Шапка Ñтраницы *********************************/
/*****/
/*----------------------------------------------------------------------------------------------------------------------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*------ ------*/
/*------ Внимание! Ðтот файл Ñодержит огромное количеÑтво Ñтилей ------*/
/*------ Ðе пытайтеÑÑŒ найти здеÑÑŒ что-то вручную ------*/
/*------ Ð”Ð»Ñ Ð¿Ð¾Ð¸Ñка Ð½Ð°Ð·Ð²Ð°Ð½Ð¸Ñ Ð½ÑƒÐ¶Ð½Ð¾Ð³Ð¾ ÑÑ‚Ð¸Ð»Ñ Ð¸Ñпользуйте Firebug: ------*/
/*------ http://articles/chto-takoe-firebug-i-pochemu-ego-objazatelno-nado-ustanovit.html ------*/
/*------ ------*/
/*------ Краткое руководÑтво по Ñозданию шаблона: ------*/
/*------ http://articles/sozdanie-shablona.html ------*/
/*------ ------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*
tttttttttttttt
*/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}