use strict;
my $str = '/***************************** Шапка Ñтраницы *********************************/
/*****/
/*----------------------------------------------------------------------------------------------------------------------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*------ ------*/
/*------ Внимание! Ðтот файл Ñодержит огромное количеÑтво Ñтилей ------*/
/*------ Ðе пытайтеÑÑŒ найти здеÑÑŒ что-то вручную ------*/
/*------ Ð”Ð»Ñ Ð¿Ð¾Ð¸Ñка Ð½Ð°Ð·Ð²Ð°Ð½Ð¸Ñ Ð½ÑƒÐ¶Ð½Ð¾Ð³Ð¾ ÑÑ‚Ð¸Ð»Ñ Ð¸Ñпользуйте Firebug: ------*/
/*------ http://articles/chto-takoe-firebug-i-pochemu-ego-objazatelno-nado-ustanovit.html ------*/
/*------ ------*/
/*------ Краткое руководÑтво по Ñозданию шаблона: ------*/
/*------ http://articles/sozdanie-shablona.html ------*/
/*------ ------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*----------------------------------------------------------------------------------------------------------------------*/
/*
tttttttttttttt
*/';
my $regex = qr/(\/\*\s*)(?'comment'.*?)(\s*\*\/)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}