# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Put server in Maintenance mode for .* at )\d{2}:\d{2}:\d{2}/$1 13:30:00/gm;t' <<< "Put server in Maintenance mode for FC1.2 Deployment at 13:30:00 GMT-0500 (Mountain Daylight Time) on Thu Jun 29 2023"