re = /(Put server in Maintenance mode for .* at )\d{2}:\d{2}:\d{2}/m
str = 'Put server in Maintenance mode for FC1.2 Deployment at 13:30:00 GMT-0500 (Mountain Daylight Time) on Thu Jun 29 2023'
subst = '$1 13:30:00'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result