package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Put server in Maintenance mode for .* at )\d{2}:\d{2}:\d{2}`)
var str = `Put server in Maintenance mode for FC1.2 Deployment at 13:30:00 GMT-0500 (Mountain Daylight Time) on Thu Jun 29 2023`
var substitution = "$1 13:30:00"
fmt.Println(re.ReplaceAllString(str, substitution))
}