import Foundation
let pattern = #"(Put server in Maintenance mode for .* at )\d{2}:\d{2}:\d{2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Put server in Maintenance mode for FC1.2 Deployment at 13:30:00 GMT-0500 (Mountain Daylight Time) on Thu Jun 29 2023"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 13:30:00"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)