const regex = new RegExp('(Put server in Maintenance mode for .* at )\\d{2}:\\d{2}:\\d{2}', 'gm')
const str = `Put server in Maintenance mode for FC1.2 Deployment at 13:30:00 GMT-0500 (Mountain Daylight Time) on Thu Jun 29 2023`;
const subst = `$1 13:30:00`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);