using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<name>[A-Z][a-z]{3,7})(\s+(?<family>[A-Z][a-z]{2,}))?(\s+(?<facultyNumber>\d{5,10}))?$";
string input = @"Valid All 12345
Valid Names
With 123456
Name
Invalid Faculcy 111111111111111
Invalid family 22222222
invalid Name 33333333
Verylongname Error
InvaliD Name 44444
Invalid FamilY 55555
Name12345
Long Familiiiiiiiiiiiiiiiii 12345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}