$re = '/^(?<name>[A-Z][a-z]{3,7})(\s+(?<family>[A-Z][a-z]{2,}))?(\s+(?<facultyNumber>\d{5,10}))?$/m';
$str = 'Valid All 12345
Valid Names
With 123456
Name
Invalid Faculcy 111111111111111
Invalid family 22222222
invalid Name 33333333
Verylongname Error
InvaliD Name 44444
Invalid FamilY 55555
Name12345
Long Familiiiiiiiiiiiiiiiii 12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);