import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<name>[A-Z][a-z]{3,7})(\\s+(?<family>[A-Z][a-z]{2,}))?(\\s+(?<facultyNumber>\\d{5,10}))?$";
final String string = "Valid All 12345\n"
+ "Valid Names\n"
+ "With 123456\n"
+ "Name\n"
+ "Invalid Faculcy 111111111111111\n"
+ "Invalid family 22222222\n"
+ "invalid Name 33333333\n"
+ "Verylongname Error\n"
+ "InvaliD Name 44444\n"
+ "Invalid FamilY 55555\n"
+ "Name12345\n"
+ "Long Familiiiiiiiiiiiiiiiii 12345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}