const regex = /^(?<name>[A-Z][a-z]{3,7})(\s+(?<family>[A-Z][a-z]{2,}))?(\s+(?<facultyNumber>\d{5,10}))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<name>[A-Z][a-z]{3,7})(\\s+(?<family>[A-Z][a-z]{2,}))?(\\s+(?<facultyNumber>\\d{5,10}))?$', 'gm')
const str = `Valid All 12345
Valid Names
With 123456
Name
Invalid Faculcy 111111111111111
Invalid family 22222222
invalid Name 33333333
Verylongname Error
InvaliD Name 44444
Invalid FamilY 55555
Name12345
Long Familiiiiiiiiiiiiiiiii 12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}