// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<name>[A-Z][a-z]{3,7})(\s+(?<family>[A-Z][a-z]{2,}))?(\s+(?<facultyNumber>\d{5,10}))?$").unwrap();
let string = "Valid All 12345
Valid Names
With 123456
Name
Invalid Faculcy 111111111111111
Invalid family 22222222
invalid Name 33333333
Verylongname Error
InvaliD Name 44444
Invalid FamilY 55555
Name12345
Long Familiiiiiiiiiiiiiiiii 12345";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}