use strict;
my $str = 'Valid All 12345
Valid Names
With 123456
Name
Invalid Faculcy 111111111111111
Invalid family 22222222
invalid Name 33333333
Verylongname Error
InvaliD Name 44444
Invalid FamilY 55555
Name12345
Long Familiiiiiiiiiiiiiiiii 12345';
my $regex = qr/^(?<name>[A-Z][a-z]{3,7})(\s+(?<family>[A-Z][a-z]{2,}))?(\s+(?<facultyNumber>\d{5,10}))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}